CreateCurveGeometryInfo Method (ExporterIFC, Transform, XYZ, Boolean)


Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static IFCGeometryInfo CreateCurveGeometryInfo(
	ExporterIFC ExporterIFC,
	Transform lcs,
	XYZ projectionDir,
	bool planViewOnly
)
Visual Basic
Public Shared Function CreateCurveGeometryInfo ( _
	ExporterIFC As ExporterIFC, _
	lcs As Transform, _
	projectionDir As XYZ, _
	planViewOnly As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateCurveGeometryInfo(
	ExporterIFC^ ExporterIFC, 
	Transform^ lcs, 
	XYZ^ projectionDir, 
	bool planViewOnly
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
lcs
Type: Autodesk.Revit.DBTransform
The local coordinate system that defines the plane in which the curve handles must lie.
projectionDir
Type: Autodesk.Revit.DBXYZ
The normal vector to the input plane.
planViewOnly
Type: SystemBoolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.

Return Value

The new geometry info container.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also