CreateCurveGeometryInfo Method (ExporterIFC, Transform, XYZ, Boolean)


IFCGeometry Info Create Curve Geometry Info Method

Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCGeometryInfo CreateCurveGeometryInfo(
	ExporterIFC ExporterIFC,
	Transform lcs,
	XYZ projectionDir,
	bool planViewOnly
)

Parameters

ExporterIFC ExporterIFC
The exporter.
lcs Transform
The local coordinate system that defines the plane in which the curve handles must lie.
projectionDir XYZ
The normal vector to the input plane.
planViewOnly Boolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.

Return Value

IFCGeometryInfo
The new geometry info container.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also