Constructor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- resolution
- Type: Autodesk.Revit.DB ConnectionResolution
Resolution type.
- reason
- Type: Autodesk.Revit.DB ConnectionWarning
Warning reason.
- part1
- Type: Autodesk.Revit.DB ElementId
First element Id.
- part2
- Type: Autodesk.Revit.DB ElementId
Second element Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |