ConnectionValidationWarning Constructor


Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public ConnectionValidationWarning(
	ConnectionResolution resolution,
	ConnectionWarning reason,
	ElementId part1,
	ElementId part2
)
Visual Basic
Public Sub New ( _
	resolution As ConnectionResolution, _
	reason As ConnectionWarning, _
	part1 As ElementId, _
	part2 As ElementId _
)
Visual C++
public:
ConnectionValidationWarning(
	ConnectionResolution resolution, 
	ConnectionWarning reason, 
	ElementId^ part1, 
	ElementId^ part2
)

Parameters

resolution
Type: Autodesk.Revit.DBConnectionResolution
Resolution type.
reason
Type: Autodesk.Revit.DBConnectionWarning
Warning reason.
part1
Type: Autodesk.Revit.DBElementId
First element Id.
part2
Type: Autodesk.Revit.DBElementId
Second element Id.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also