ConnectionValidationWarning Constructor


Connection Validation Warning Constructor

Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ConnectionValidationWarning(
	ConnectionResolution resolution,
	ConnectionWarning reason,
	ElementId part1,
	ElementId part2
)

Parameters

resolution ConnectionResolution
Resolution type.
reason ConnectionWarning
Warning reason.
part1 ElementId
First element Id.
part2 ElementId
Second element Id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also