Adds a Ribbon item to the panel.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- itemData
- Type: Autodesk.Revit.UI RibbonItemData
Data containing information about the new item.
Return Value
The added Ribbon item.Remarks
The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in. The new item may be created as a large-size vertical control in the panel.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when itemData is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type. |