Ribbon |
Adds a Ribbon item to the panel.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- itemData RibbonItemData
- Data containing information about the new item.
Return Value
RibbonItemThe added Ribbon item.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when itemData is . |
ArgumentException | Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type. |

The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in. The new item may be created as a large-size vertical control in the panel.