AddItem Method


Ribbon Panel Add Item Method

Adds a Ribbon item to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RibbonItem AddItem(
	RibbonItemData itemData
)

Parameters

itemData RibbonItemData
Data containing information about the new item.

Return Value

RibbonItem
The added Ribbon item.
Exceptions
Exception Condition
ArgumentNullException Thrown when itemData is .
ArgumentException Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type.
Remarks
The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in. The new item may be created as a large-size vertical control in the panel.
See Also