InitialIlluminanceIntensity Constructor (Double, Double)


Creates an initial illuminance intensity object with the given document and illuminance values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public InitialIlluminanceIntensity(
	double distance,
	double illuminance
)
Visual Basic
Public Sub New ( _
	distance As Double, _
	illuminance As Double _
)
Visual C++
public:
InitialIlluminanceIntensity(
	double distance, 
	double illuminance
)

Parameters

distance
Type: System Double
The illuminance distance value in feet as a numerical value between 0 and 1e+30.
illuminance
Type: System Double
The illuminance value in lx as a numerical value between 0 and 1e+30.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException The distance value is not valid because it is not between 0 and 1e+30. -or- The illuminance value is not valid because it is not between 0 and 1e+30.

See Also