Creates an initial illuminance intensity object with the given document and illuminance values.
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- distance
- Type: SystemDouble
The illuminance distance value in feet as a numerical value between 0 and 1e+30.
- illuminance
- Type: SystemDouble
The illuminance value in lx as a numerical value between 0 and 1e+30.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The distance value is not valid because it is not between 0 and 1e+30. -or- The illuminance value is not valid because it is not between 0 and 1e+30. |