InitialIlluminanceIntensity Constructor (Double, Double)


Initial Illuminance Intensity(Double, Double) Constructor

Creates an initial illuminance intensity object with the given document and illuminance values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public InitialIlluminanceIntensity(
	double distance,
	double illuminance
)

Parameters

distance Double
The illuminance distance value in feet as a numerical value between 0 and 1e+30.
illuminance Double
The illuminance value in lx as a numerical value between 0 and 1e+30.
Exceptions
Exception Condition
ArgumentOutOfRangeException The distance value is not valid because it is not between 0 and 1e+30. -or- The illuminance value is not valid because it is not between 0 and 1e+30.
See Also