This method will return the fabrication id for the given reference.
Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
Document to which the reference belongs.
- reference
- Type: Autodesk.Revit.DB Reference
The reference to the element or subelement for which fabrication id is required.
Return Value
The fabrication id of the element or subelement for this reference, if it has fabrication information attached, or an Guid.Empty otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |