Steel |
This method will return the fabrication id for the given reference.
Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- aDoc Document
- Document to which the reference belongs.
- reference Reference
- The reference to the element or subelement for which fabrication id is required.
Return Value
GuidThe fabrication id of the element or subelement for this reference, if it has fabrication information attached, or an Guid.Empty otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |