This method will return the fabrication id for the given reference.
Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DBDocument
Document to which the reference belongs.
- reference
- Type: Autodesk.Revit.DBReference
The reference to the element or subelement for which fabrication id is required.
Return Value
The fabrication id of the element or subelement for this reference, if it has fabrication information attached, or an Guid.Empty otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |