Creates a fabrication part element from a fabrication item file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- itemFile
- Type: Autodesk.Revit.DB FabricationItemFile
The fabrication item file.
- levelId
- Type: Autodesk.Revit.DB ElementId
The element identifier associated with the Level the FabricationPart will be created on.
Return Value
The new fabrication part.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The item file is not valid for use in Revit. -or- The item file has not been loaded into the configuration. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |