Create Method (Document, FabricationItemFile, ElementId)


Fabrication Part Create(Document, Fabrication Item File, Element Id) Method

Creates a fabrication part element from a fabrication item file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricationPart Create(
	Document document,
	FabricationItemFile itemFile,
	ElementId levelId
)

Parameters

document Document
The document.
itemFile FabricationItemFile
The fabrication item file.
levelId ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

FabricationPart
The new fabrication part.
Exceptions
Exception Condition
ArgumentException The item file is not valid for use in Revit. -or- The item file has not been loaded into the configuration. -or- The ElementId levelId is not a Level.
ArgumentNullException A non-optional argument was null
See Also