Creates a fabrication part element from a fabrication item file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- itemFile
- Type: Autodesk.Revit.DBFabricationItemFile
The fabrication item file.
- levelId
- Type: Autodesk.Revit.DBElementId
The element identifier associated with the Level the FabricationPart will be created on.
Return Value
The new fabrication part.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The item file is not valid for use in Revit. -or- The item file has not been loaded into the configuration. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |