Replace the current initial color object with the given object
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- initialColor
- Type: Autodesk.Revit.DB.Lighting InitialColor
An object derived from an InitialColor object The object pointed to is cloned internally
Remarks
The argument object is cloned
Examples

public void SetInitialColorProperty(LightType lightType)
{
InitialColor initialColor = lightType.GetInitialColor();
if (initialColor is CustomInitialColor)
{
CustomInitialColor custom = initialColor as CustomInitialColor;
double colorTemperature = custom.Temperature;
// Set new value for color temperature and set modified initial color to LightType.
custom.Temperature = 3450.0;
lightType.SetInitialColor(custom);
// Create a PresetInitialColor and set it to LightType.
PresetInitialColor preset = new PresetInitialColor(ColorPreset.Halogen);
lightType.SetInitialColor(preset);
}
}

Public Sub SetInitialColorProperty(lightType As LightType)
Dim initialColor As InitialColor = lightType.GetInitialColor()
If TypeOf initialColor Is CustomInitialColor Then
Dim [custom] As CustomInitialColor = TryCast(initialColor, CustomInitialColor)
Dim colorTemperature As Double = [custom].Temperature
' Set new value for color temperature and set modified initial color to LightType.
[custom].Temperature = 3450.0
lightType.SetInitialColor([custom])
' Create a PresetInitialColor and set it to LightType.
Dim preset As New PresetInitialColor(ColorPreset.Halogen)
lightType.SetInitialColor(preset)
End If
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |