Creates a new instance of a point cloud based on an input point cloud type and transformation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which the new instance is created
- typeId
- Type: Autodesk.Revit.DB ElementId
The element id of the PointCloudType.
- transform
- Type: Autodesk.Revit.DB Transform
The transform that defines the placement of the instance in the Revit document coordinate system.
Return Value
The newly created point cloud instance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId typeId is not a valid PointCloudType. -or- document is not a project document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |