Point |
Creates a new instance of a point cloud based on an input point cloud type and transformation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PointCloudInstance Create(
Document document,
ElementId typeId,
Transform transform
)
Parameters
- document Document
- The document in which the new instance is created
- typeId ElementId
- The element id of the PointCloudType.
- transform Transform
- The transform that defines the placement of the instance in the Revit document coordinate system.
Return Value
PointCloudInstanceThe newly created point cloud instance.

Exception | Condition |
---|---|
ArgumentException | The ElementId typeId is not a valid PointCloudType. -or- document is not a project document. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |