Create Method


Creates a new instance of a point cloud based on an input point cloud type and transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static PointCloudInstance Create(
	Document document,
	ElementId typeId,
	Transform transform
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	typeId As ElementId, _
	transform As Transform _
) As PointCloudInstance
Visual C++
public:
static PointCloudInstance^ Create(
	Document^ document, 
	ElementId^ typeId, 
	Transform^ transform
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which the new instance is created
typeId
Type: Autodesk.Revit.DBElementId
The element id of the PointCloudType.
transform
Type: Autodesk.Revit.DBTransform
The transform that defines the placement of the instance in the Revit document coordinate system.

Return Value

The newly created point cloud instance.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId typeId is not a valid PointCloudType. -or- document is not a project document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also