GetActiveServerIds Method (Document)


Returns Ids of the servers currently applicable to the given document for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public IList<Guid> GetActiveServerIds(
	Document document
)
Visual Basic
Public Function GetActiveServerIds ( _
	document As Document _
) As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetActiveServerIds(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB Document
The associated document.

Return Value

A set of GUIDs of the document-applicable active servers; the list may be empty.

Remarks

The Ids would be of all the servers explicitly assigned to the specified document.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also