Returns Ids of the servers currently applicable to the given document for the service.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The associated document.
Return Value
A set of GUIDs of the document-applicable active servers; the list may be empty.Remarks
The Ids would be of all the servers explicitly assigned to the specified document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |