Checks if given type is valid for the set of elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- elementIds
- Type: System.Collections.Generic ICollection ElementId
A collection of element IDs.
- typeId
- Type: Autodesk.Revit.DB ElementId
ElementId of the type to check.
Return Value
True if all elements can have a type assigned and this type is valid for all elements, false otherwise.Remarks
A type is valid for the set of elements if it is valid for each and every element in the set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when at least one of the elements does not exist in the document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |