IsValidType Method (Document, ICollection(ElementId), ElementId)


Element Is Valid Type(Document, ICollection Element Id , Element Id) Method

Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidType(
	Document document,
	ICollection<ElementId> elementIds,
	ElementId typeId
)

Parameters

document Document
The document.
elementIds ICollection ElementId
A collection of element IDs.
typeId ElementId
ElementId of the type to check.

Return Value

Boolean
True if all elements can have a type assigned and this type is valid for all elements, false otherwise.
Exceptions
Exception Condition
ArgumentException Thrown when at least one of the elements does not exist in the document.
ArgumentNullException A non-optional argument was null
Remarks
A type is valid for the set of elements if it is valid for each and every element in the set.
See Also