IsValidType Method (Document, ICollection(ElementId), ElementId)


Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool IsValidType(
	Document document,
	ICollection<ElementId> elementIds,
	ElementId typeId
)
Visual Basic
Public Shared Function IsValidType ( _
	document As Document, _
	elementIds As ICollection(Of ElementId), _
	typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidType(
	Document^ document, 
	ICollection<ElementId^>^ elementIds, 
	ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
elementIds
Type: System.Collections.GenericICollectionElementId
A collection of element IDs.
typeId
Type: Autodesk.Revit.DBElementId
ElementId of the type to check.

Return Value

True if all elements can have a type assigned and this type is valid for all elements, false otherwise.

Remarks

A type is valid for the set of elements if it is valid for each and every element in the set.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also