Creates a new linear dimension object using the specified dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the dimension is to be visible.
- line
- Type: Autodesk.Revit.DB Line
The extension line of the dimension.
- references
- Type: Autodesk.Revit.DB ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
- dimensionType
- Type: Autodesk.Revit.DB DimensionType
The dimension style to be used for the dimension.
Return Value
If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when any input argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the argument is invalid. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the creation failed. |