NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)


Family Item Factory New Linear Dimension(View, Line, Reference Array, Dimension Type) Method

Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Dimension NewLinearDimension(
	View view,
	Line line,
	ReferenceArray references,
	DimensionType dimensionType
)

Parameters

view View
The view in which the dimension is to be visible.
line Line
The extension line of the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when any input argument is .
ArgumentException Thrown when the argument is invalid.
InvalidOperationException Thrown when the creation failed.
See Also