NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)


Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewLinearDimension(
	View view,
	Line line,
	ReferenceArray references,
	DimensionType dimensionType
)
Visual Basic
Public Function NewLinearDimension ( _
	view As View, _
	line As Line, _
	references As ReferenceArray, _
	dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
	View^ view, 
	Line^ line, 
	ReferenceArray^ references, 
	DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DBView
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DBLine
The extension line of the dimension.
references
Type: Autodesk.Revit.DBReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType
Type: Autodesk.Revit.DBDimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when any input argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the argument is invalid.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the creation failed.

See Also