Check that all families loaded in the host document have their content documents.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The host document.
- corruptFamilyIds
- Type: System.Collections.Generic ISet ElementId
Return ids of families that need to be reloaded because their content documents are missing.
Return Value
Returns true if all loaded families have their content documents.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |