CheckAllFamilies Method


Check that all families loaded in the host document have their content documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool CheckAllFamilies(
	Document ADoc,
	ISet<ElementId> corruptFamilyIds
)
Visual Basic
Public Shared Function CheckAllFamilies ( _
	ADoc As Document, _
	corruptFamilyIds As ISet(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CheckAllFamilies(
	Document^ ADoc, 
	ISet<ElementId^>^ corruptFamilyIds
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
The host document.
corruptFamilyIds
Type: System.Collections.GenericISetElementId
Return ids of families that need to be reloaded because their content documents are missing.

Return Value

Returns true if all loaded families have their content documents.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also