Creates a new FormatOptions object that represents custom formatting.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the unit to display.
- symbolTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the symbol with which to render the unit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | symbolTypeId is not a valid symbol for unitTypeId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |