FormatOptions Constructor (ForgeTypeId, ForgeTypeId)


Format Options(Forge Type Id, Forge Type Id) Constructor

Creates a new FormatOptions object that represents custom formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FormatOptions(
	ForgeTypeId unitTypeId,
	ForgeTypeId symbolTypeId
)

Parameters

unitTypeId ForgeTypeId
Identifier of the unit to display.
symbolTypeId ForgeTypeId
Identifier of the symbol with which to render the unit.
Exceptions
Exception Condition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- symbolTypeId is not a valid symbol for unitTypeId.
ArgumentNullException A non-optional argument was null
See Also