Creates a new FormatOptions object that represents custom formatting.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit to display.
- symbolTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the symbol with which to render the unit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- symbolTypeId is not a valid symbol for unitTypeId. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |