Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyInstance
- Type: Autodesk.Revit.DB FamilyInstance
The family instance.
Return Value
True if the instance has its own geometry. False if the symbol's geometry is used.Remarks
A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform. This method identifies the source of this family instance's geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |