UsesInstanceGeometry Method


Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool UsesInstanceGeometry(
	FamilyInstance familyInstance
)
Visual Basic
Public Shared Function UsesInstanceGeometry ( _
	familyInstance As FamilyInstance _
) As Boolean
Visual C++
public:
static bool UsesInstanceGeometry(
	FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The family instance.

Return Value

True if the instance has its own geometry. False if the symbol's geometry is used.

Remarks

A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform. This method identifies the source of this family instance's geometry.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also