Add CurtainGrid on the specified face for the CurtainSystem.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Reference
The face new CurtainGrid will be created on.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument face is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails. |