Get (or create) the IfcFillPatternStyle associated with an ElementId.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fillPatternId
- Type: Autodesk.Revit.DB ElementId
The fill pattern id.
- color
- Type: Autodesk.Revit.DB Color
The pattern color.
- planScale
- Type: System Double
The view scale.
Return Value
The IfcSurfaceStyle.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |