Exporter |
Get (or create) the IfcFillPatternStyle associated with an ElementId.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public IFCAnyHandle GetOrCreateFillPattern(
ElementId fillPatternId,
Color color,
double planScale
)
Parameters
- fillPatternId ElementId
- The fill pattern id.
- color Color
- The pattern color.
- planScale Double
- The view scale.
Return Value
IFCAnyHandleThe IfcSurfaceStyle.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |