GetOrCreateFillPattern Method


Get (or create) the IfcFillPatternStyle associated with an ElementId.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public IFCAnyHandle GetOrCreateFillPattern(
	ElementId fillPatternId,
	Color color,
	double planScale
)
Visual Basic
Public Function GetOrCreateFillPattern ( _
	fillPatternId As ElementId, _
	color As Color, _
	planScale As Double _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOrCreateFillPattern(
	ElementId^ fillPatternId, 
	Color^ color, 
	double planScale
)

Parameters

fillPatternId
Type: Autodesk.Revit.DBElementId
The fill pattern id.
color
Type: Autodesk.Revit.DBColor
The pattern color.
planScale
Type: SystemDouble
The view scale.

Return Value

The IfcSurfaceStyle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also