Gets the host face to which the CurveElement is added.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveElem
- Type: Autodesk.Revit.DB CurveElement
The CurveElement.
Return Value
The host face to which the CurveElement is added, or an empty Reference if the host is not a face.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input CurveElement is not a CurveByPoints. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |