GetHostFace Method


Gets the host face to which the CurveElement is added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static Reference GetHostFace(
	CurveElement curveElem
)
Visual Basic
Public Shared Function GetHostFace ( _
	curveElem As CurveElement _
) As Reference
Visual C++
public:
static Reference^ GetHostFace(
	CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DBCurveElement
The CurveElement.

Return Value

The host face to which the CurveElement is added, or an empty Reference if the host is not a face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input CurveElement is not a CurveByPoints.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also