Creates new areas
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dataList
- Type: System.Collections.Generic List AreaCreationData
A list of AreaCreationData which wraps the creation arguments of the areas to be created.
Return Value
If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | If AreaCreationData's areaPoint is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation. |