NewAreas Method


Document New Areas Method

Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementSet NewAreas(
	List<AreaCreationData> dataList
)

Parameters

dataList List AreaCreationData
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

ElementSet
If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.
Exceptions
Exception Condition
ArgumentNullException If AreaCreationData's areaPoint is .
InvalidOperationException If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.
See Also