NewAreas Method


Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ElementSet NewAreas(
	List<AreaCreationData> dataList
)
Visual Basic
Public Function NewAreas ( _
	dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
	List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.GenericListAreaCreationData
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException If AreaCreationData's areaPoint is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationExceptionIf the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also