Creates a new ElevationMarker.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to which the new ElevationMarker will be added.
- viewFamilyTypeId
- Type: Autodesk.Revit.DB ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
- origin
- Type: Autodesk.Revit.DB XYZ
The desired origin for the ElevationMarker.
- initialViewScale
- Type: System Int32
This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.
Return Value
The new ElevationMarker.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |