Elevation |
Creates a new ElevationMarker.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElevationMarker CreateElevationMarker(
Document document,
ElementId viewFamilyTypeId,
XYZ origin,
int initialViewScale
)
Parameters
- document Document
- The document to which the new ElevationMarker will be added.
- viewFamilyTypeId ElementId
- This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
- origin XYZ
- The desired origin for the ElevationMarker.
- initialViewScale Int32
- This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.
Return Value
ElevationMarkerThe new ElevationMarker.

Exception | Condition |
---|---|
ArgumentException | This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family. |
ArgumentNullException | A non-optional argument was null |