CreateElevationMarker Method


Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static ElevationMarker CreateElevationMarker(
	Document document,
	ElementId viewFamilyTypeId,
	XYZ origin,
	int initialViewScale
)
Visual Basic
Public Shared Function CreateElevationMarker ( _
	document As Document, _
	viewFamilyTypeId As ElementId, _
	origin As XYZ, _
	initialViewScale As Integer _
) As ElevationMarker
Visual C++
public:
static ElevationMarker^ CreateElevationMarker(
	Document^ document, 
	ElementId^ viewFamilyTypeId, 
	XYZ^ origin, 
	int initialViewScale
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the new ElevationMarker will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DBElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin
Type: Autodesk.Revit.DBXYZ
The desired origin for the ElevationMarker.
initialViewScale
Type: SystemInt32
This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.

Return Value

The new ElevationMarker.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also