UpdateMultiple Method (Document, IList(ElementId))


Updates the specified paths of travel by recalculating each path using their original start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020

Syntax

C#
public static int UpdateMultiple(
	Document adoc,
	IList<ElementId> elementsToUpdate
)
Visual Basic
Public Shared Function UpdateMultiple ( _
	adoc As Document, _
	elementsToUpdate As IList(Of ElementId) _
) As Integer
Visual C++
public:
static int UpdateMultiple(
	Document^ adoc, 
	IList<ElementId^>^ elementsToUpdate
)

Parameters

adoc
Type: Autodesk.Revit.DB Document
Document of elements to be updated.
elementsToUpdate
Type: System.Collections.Generic IList ElementId
The list of ElementId of the paths to update.

Return Value

number of successfully updated elements

Remarks

For unsuccessfully updated elements, Revit will post warnings.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException This functionality is not available in Revit LT.

See Also