UpdateMultiple Method (Document, IList(ElementId))


Path Of Travel Update Multiple(Document, IList Element Id ) Method

Updates the specified paths of travel by recalculating each path using their original start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static int UpdateMultiple(
	Document adoc,
	IList<ElementId> elementsToUpdate
)

Parameters

adoc Document
Document of elements to be updated.
elementsToUpdate IList ElementId
The list of ElementId of the paths to update.

Return Value

Int32
number of successfully updated elements
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException This functionality is not available in Revit LT.
Remarks
For unsuccessfully updated elements, Revit will post warnings.
See Also